summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-03 12:46:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-03 20:11:37 +0100
commit3bec8a016ff61e3e5dd1af86ee8423af4c168720 (patch)
tree7389e52f748f1219aa6a8bbfbf034a2333e2e852 /gnu
parentaa8c0ada2ef4b854444f153906b4c68d012ae7ae (diff)
downloadguix-patches-3bec8a016ff61e3e5dd1af86ee8423af4c168720.tar
guix-patches-3bec8a016ff61e3e5dd1af86ee8423af4c168720.tar.gz
gnu: git: Fix gitweb.
* gnu/packages/version-control.scm (git)[inputs]: Add perl-cgi. [arguments]: Wrap "gitweb.cgi" with PERL5LIB.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 03d7bbead3..edd2d3a4dd 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -141,6 +141,9 @@ as well as the classic centralized workflow.")
("python" ,python-2) ; CAVEAT: incompatible with python-3 according to INSTALL
("zlib" ,zlib)
+ ;; For 'gitweb.cgi'
+ ("perl-cgi" ,perl-cgi)
+
;; For 'git-svn'.
("subversion" ,subversion)
("perl-term-readkey" ,perl-term-readkey)
@@ -257,6 +260,17 @@ as well as the classic centralized workflow.")
"perl-net-smtp-ssl"
"perl-io-socket-ssl")))))))
+ ;; Tell 'gitweb.cgi' where perl modules are.
+ (wrap-program (string-append out "/share/gitweb/gitweb.cgi")
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (o) (string-append o "/lib/perl5/site_perl"))
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (inputs)))
+ '("perl-cgi")))))))
+
;; Tell 'git-submodule' where Perl is.
(wrap-program git-sm
`("PATH" ":" prefix