summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2016-12-01 12:51:20 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-03 18:55:01 +0100
commitaa8c0ada2ef4b854444f153906b4c68d012ae7ae (patch)
tree7adbdee0d7ec3f39f5f34b2bdfb5e1e086bad197 /gnu
parentf447dbc79660c6a50c2d8f1a5f47fce966d9baf8 (diff)
downloadguix-patches-aa8c0ada2ef4b854444f153906b4c68d012ae7ae.tar
guix-patches-aa8c0ada2ef4b854444f153906b4c68d012ae7ae.tar.gz
gnu: Add grantlee.
* gnu/packages/qt.scm (grantlee): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index b442356530..ae951aad5f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cups)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
@@ -59,6 +60,38 @@
#:use-module (gnu packages xorg)
#:use-module (gnu packages xml))
+(define-public grantlee
+ (package
+ (name "grantlee")
+ (version "5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/steveire/grantlee/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1lf9rkv0i0kd7fvpgg5l8jb87zw8dzcwd1liv6hji7g4wlpmfdiq"))))
+ (native-inputs
+ `(("doxygen" ,doxygen)))
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (zero? (system* "ctest" ;; exclude 2 tests which require a display
+ "-E" "htmlbuildertest|plainmarkupbuildertest")))))))
+ (home-page "https://github.com/steveire/grantlee")
+ (synopsis "Libraries for text templating with Qt")
+ (description "Grantlee Templates can be used for theming and generation of
+other text such as code. The syntax uses the syntax of the Django template
+system, and the core design of Django is reused in Grantlee.")
+ (license license:lgpl2.0+)))
+
(define-public qt
(package
(name "qt")