summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 03d7bbead3..edd2d3a4dd 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -141,6 +141,9 @@ as well as the classic centralized workflow.")
("python" ,python-2) ; CAVEAT: incompatible with python-3 according to INSTALL
("zlib" ,zlib)
+ ;; For 'gitweb.cgi'
+ ("perl-cgi" ,perl-cgi)
+
;; For 'git-svn'.
("subversion" ,subversion)
("perl-term-readkey" ,perl-term-readkey)
@@ -257,6 +260,17 @@ as well as the classic centralized workflow.")
"perl-net-smtp-ssl"
"perl-io-socket-ssl")))))))
+ ;; Tell 'gitweb.cgi' where perl modules are.
+ (wrap-program (string-append out "/share/gitweb/gitweb.cgi")
+ `("PERL5LIB" ":" prefix
+ ,(map (lambda (o) (string-append o "/lib/perl5/site_perl"))
+ (list
+ ,@(transitive-input-references
+ 'inputs
+ (map (lambda (l)
+ (assoc l (inputs)))
+ '("perl-cgi")))))))
+
;; Tell 'git-submodule' where Perl is.
(wrap-program git-sm
`("PATH" ":" prefix