summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-27 13:57:35 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-27 13:57:45 +0200
commit5c81cbda5e1c97b5234f48f36de28adcccaa3555 (patch)
treeec3e5eb0965645f393e266655a19028e8bcc748a /gnu/packages/textutils.scm
parentb0020938e17ac4d7f9f87d9bb7ff2d2dbdd7c33f (diff)
downloadguix-patches-5c81cbda5e1c97b5234f48f36de28adcccaa3555.tar
guix-patches-5c81cbda5e1c97b5234f48f36de28adcccaa3555.tar.gz
gnu: html2text: Fix cross-compilation.
* gnu/packages/textutils.scm (html2text)[arguments]: Set $CXX to the correct (CC-FOR-TARGET).
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 0df8399ffd..96bb7be468 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1038,7 +1038,8 @@ indentation.
;; The configure script is not from autotools and does not accept
;; ‘--style’ options. There is no proper error handling.
(lambda* (#:key outputs #:allow-other-keys)
- (invoke "./configure"))))))
+ (invoke "./configure"
+ (string-append "CXX=" ,(cxx-for-target))))))))
(home-page "https://github.com/grobian/html2text")
(synopsis "HTML to plain text converter")
(description