summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-27 13:54:41 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-04-27 13:54:44 +0200
commitb0020938e17ac4d7f9f87d9bb7ff2d2dbdd7c33f (patch)
tree42c607b73730533956e51735b3d210b40ea7fb98 /gnu/packages/textutils.scm
parentb43e9c8ecd44b597936033eb441f50980d00c398 (diff)
downloadguix-patches-b0020938e17ac4d7f9f87d9bb7ff2d2dbdd7c33f.tar
guix-patches-b0020938e17ac4d7f9f87d9bb7ff2d2dbdd7c33f.tar.gz
gnu: html2text: Run ./configure without errors.
* gnu/packages/textutils.scm (html2text)[arguments]: Add a custom 'configure phase. Replace the custom 'fix-paths phase with the customary #:make-flags equivalent.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 398bfc28ca..0df8399ffd 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1030,13 +1030,15 @@ indentation.
(base32 "0n6pl0nijcn4z3p0dvf3gmvvpjq261pagnk84s9f78c4c55bw5cm"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
+ (replace 'configure
+ ;; The configure script is not from autotools and does not accept
+ ;; ‘--style’ options. There is no proper error handling.
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile.in"
- (("/usr/local")
- (assoc-ref outputs "out"))))))))
+ (invoke "./configure"))))))
(home-page "https://github.com/grobian/html2text")
(synopsis "HTML to plain text converter")
(description