summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-05 15:13:20 -0500
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:28 -0400
commit76b6c61609fd8352ce01059307cf1aec85b8d0df (patch)
tree4163fb96545d50309d42bb9e76e85461f0c4489f /gnu/packages/python.scm
parentdc6779486759936c6a26962a473d591e4fb10e77 (diff)
downloadguix-patches-76b6c61609fd8352ce01059307cf1aec85b8d0df.tar
guix-patches-76b6c61609fd8352ce01059307cf1aec85b8d0df.tar.gz
gnu: Python: Absorb grafted replacement.
* gnu/packages/python.scm (python-3.8)[source]: Add 'python-3.8-CVE-2021-3177.patch'. [replacement]: Remove field. (python-3.8/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b8a31bcc6f..ce424bdeb0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -365,7 +365,6 @@ data types.")
(define-public python-3.8
(package (inherit python-2)
(name "python")
- (replacement python-3.8/fixed)
(version "3.8.2")
(source (origin
(method url-fetch)
@@ -373,6 +372,7 @@ data types.")
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-CVE-2020-26116.patch"
+ "python-3.8-CVE-2021-3177.patch"
"python-3-fix-tests.patch"
"python-3.8-fix-tests.patch"
"python-3-deterministic-build-info.patch"
@@ -523,14 +523,6 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
-(define python-3.8/fixed
- (package
- (inherit python-3.8)
- (source (origin
- (inherit (package-source python-3.8))
- (patches (append (search-patches "python-3.8-CVE-2021-3177.patch")
- (origin-patches (package-source python-3.8))))))))
-
(define-public python-3.9
(package (inherit python-3.8)
(name "python-next")