summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b8a31bcc6f..ce424bdeb0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -365,7 +365,6 @@ data types.")
(define-public python-3.8
(package (inherit python-2)
(name "python")
- (replacement python-3.8/fixed)
(version "3.8.2")
(source (origin
(method url-fetch)
@@ -373,6 +372,7 @@ data types.")
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-CVE-2020-26116.patch"
+ "python-3.8-CVE-2021-3177.patch"
"python-3-fix-tests.patch"
"python-3.8-fix-tests.patch"
"python-3-deterministic-build-info.patch"
@@ -523,14 +523,6 @@ data types.")
(version-major+minor version)
"/site-packages"))))))))
-(define python-3.8/fixed
- (package
- (inherit python-3.8)
- (source (origin
- (inherit (package-source python-3.8))
- (patches (append (search-patches "python-3.8-CVE-2021-3177.patch")
- (origin-patches (package-source python-3.8))))))))
-
(define-public python-3.9
(package (inherit python-3.8)
(name "python-next")