summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-05 15:15:01 -0500
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:28 -0400
commitdc6779486759936c6a26962a473d591e4fb10e77 (patch)
tree1196c46d722bc7a20e9274ab584cf0c79834be40 /gnu/packages/python.scm
parent0f7e1eed16dbe56e5873a7fdfbda514f488867ff (diff)
downloadguix-patches-dc6779486759936c6a26962a473d591e4fb10e77.tar
guix-patches-dc6779486759936c6a26962a473d591e4fb10e77.tar.gz
gnu: Python 2: Absorb grafted replacement.
* gnu/packages/python.scm (python-2.7)[source]: Add 'python-2.7-CVE-2021-3177.patch'. [replacement]: Remove field. (python-2.7/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5d8fa1185b..b8a31bcc6f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -107,7 +107,6 @@
(define-public python-2.7
(package
(name "python2")
- (replacement python-2.7/fixed)
(version "2.7.17")
(source
(origin
@@ -122,7 +121,8 @@
"python-2.7-site-prefixes.patch"
"python-2.7-source-date-epoch.patch"
"python-2.7-adjust-tests.patch"
- "python-cross-compile.patch"))
+ "python-cross-compile.patch"
+ "python-2.7-CVE-2021-3177.patch"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -351,14 +351,6 @@ data types.")
(properties '((cpe-name . "python")))
(license license:psfl)))
-(define python-2.7/fixed
- (package
- (inherit python-2.7)
- (source (origin
- (inherit (package-source python-2.7))
- (patches (append (search-patches "python-2.7-CVE-2021-3177.patch")
- (origin-patches (package-source python-2.7))))))))
-
;; Current 2.x version.
(define-public python-2 python-2.7)