summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:14:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:02 +0100
commit47c4c1fe236ee9318838492c95dabc65648eb0ed (patch)
tree96f6b1d88e8ee734e412aab0fc3e2e43ad19e7d3 /gnu/packages/cmake.scm
parenta4de5cfd2f75f19d751a2f37d758b500bfd19a7e (diff)
downloadguix-patches-47c4c1fe236ee9318838492c95dabc65648eb0ed.tar
guix-patches-47c4c1fe236ee9318838492c95dabc65648eb0ed.tar.gz
gnu: CMake: Update to 3.16.0.
* gnu/packages/cmake.scm (cmake-minimal): Update to 3.16.0. [arguments]: Adjust for renamed file. Disable test RunCMake.install. * gnu/packages/patches/cmake-curl-certificates.patch: Adjust context.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm24
1 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 135863f6c2..806a7396e9 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -51,7 +51,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.15.1")
+ (version "3.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -59,7 +59,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+ "0pwcgvk75577rdizpzjrk2n43a6l7rvfhmhn7sd6xarwqrb6b9bd"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -101,6 +101,8 @@
(let ((skipped-tests
(list "BundleUtilities" ; This test fails on Guix.
"CTestTestSubdir" ; This test fails to build 2 of the 3 tests.
+ ;; This test requires 'ldconfig' which is not available in Guix.
+ "RunCMake.install"
;; These tests requires network access.
"CTestCoverageCollectGCOV"
"CTestTestUpload")))
@@ -125,7 +127,7 @@
;; files.
(substitute*
'("Modules/CompilerId/Xcode-3.pbxproj.in"
- "Modules/CPack.RuntimeScript.in"
+ "Modules/Internal/CPack/CPack.RuntimeScript.in"
"Source/cmGlobalXCodeGenerator.cxx"
"Source/cmLocalUnixMakefileGenerator3.cxx"
"Source/cmExecProgramCommand.cxx"
@@ -218,22 +220,6 @@ and workspaces that can be used in the compiler environment of your choice.")
(search-paths
(package-native-search-paths cmake-minimal))))
-(define-public cmake-3.15.5
- ;; CMake 3.15.5 fixes some issues, but declare another version to
- ;; avoid triggering the rebuild of all CMake-based packages.
- ;; See <https://issues.guix.gnu.org/issue/38060>.
- (package
- (inherit cmake)
- (version "3.15.5")
- (source (origin
- (inherit (package-source cmake))
- (uri (string-append "https://www.cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (sha256
- (base32
- "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
-
(define-public emacs-cmake-mode
(package
(inherit cmake)