summaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:13:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:02 +0100
commita4de5cfd2f75f19d751a2f37d758b500bfd19a7e (patch)
treee26c0579a673d587697d8cd6e931cd94bde0a86e /gnu/packages/cmake.scm
parent857d443494740a04a4c1a90f9be23d955f54a7a6 (diff)
downloadguix-patches-a4de5cfd2f75f19d751a2f37d758b500bfd19a7e.tar
guix-patches-a4de5cfd2f75f19d751a2f37d758b500bfd19a7e.tar.gz
gnu: Remove cmake/fixed.
* gnu/packages/cmake.scm (cmake/fixed): Remove variable. (cmake-minimal)[source](patches): Add "cmake-curl-certificates.patch".
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 5c9b9810c8..135863f6c2 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -75,7 +75,8 @@
"cmliblzma"
;; "cmlibuv"
"cmzlib"))
- #t)))))
+ #t)))
+ (patches (search-patches "cmake-curl-certificates.patch"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -209,18 +210,6 @@ and workspaces that can be used in the compiler environment of your choice.")
(outputs '("out" "doc"))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
-(define-public cmake/fixed
- ;; This is a variant of CMake that fixes X.509 certificate lookup:
- ;; <https://issues.guix.gnu.org/issue/37371>.
- (package
- (inherit cmake)
- (version (string-append (package-version cmake) "-1"))
- (source (origin
- (inherit (package-source cmake))
- (patches
- (append (search-patches "cmake-curl-certificates.patch")
- (origin-patches (package-source cmake))))))))
-
(define-public cmake-minimal-cross
(package
(inherit cmake-minimal)