summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:14:06 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:02 +0100
commit47c4c1fe236ee9318838492c95dabc65648eb0ed (patch)
tree96f6b1d88e8ee734e412aab0fc3e2e43ad19e7d3 /gnu
parenta4de5cfd2f75f19d751a2f37d758b500bfd19a7e (diff)
downloadguix-patches-47c4c1fe236ee9318838492c95dabc65648eb0ed.tar
guix-patches-47c4c1fe236ee9318838492c95dabc65648eb0ed.tar.gz
gnu: CMake: Update to 3.16.0.
* gnu/packages/cmake.scm (cmake-minimal): Update to 3.16.0. [arguments]: Adjust for renamed file. Disable test RunCMake.install. * gnu/packages/patches/cmake-curl-certificates.patch: Adjust context.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cmake.scm24
-rw-r--r--gnu/packages/patches/cmake-curl-certificates.patch10
2 files changed, 10 insertions, 24 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 135863f6c2..806a7396e9 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -51,7 +51,7 @@
(define-public cmake-minimal
(package
(name "cmake-minimal")
- (version "3.15.1")
+ (version "3.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cmake.org/files/v"
@@ -59,7 +59,7 @@
"/cmake-" version ".tar.gz"))
(sha256
(base32
- "1xyprly3sf4wi0n1x79k4n22yxm6pb7fv70gqr9lvc7qv14cbphq"))
+ "0pwcgvk75577rdizpzjrk2n43a6l7rvfhmhn7sd6xarwqrb6b9bd"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -101,6 +101,8 @@
(let ((skipped-tests
(list "BundleUtilities" ; This test fails on Guix.
"CTestTestSubdir" ; This test fails to build 2 of the 3 tests.
+ ;; This test requires 'ldconfig' which is not available in Guix.
+ "RunCMake.install"
;; These tests requires network access.
"CTestCoverageCollectGCOV"
"CTestTestUpload")))
@@ -125,7 +127,7 @@
;; files.
(substitute*
'("Modules/CompilerId/Xcode-3.pbxproj.in"
- "Modules/CPack.RuntimeScript.in"
+ "Modules/Internal/CPack/CPack.RuntimeScript.in"
"Source/cmGlobalXCodeGenerator.cxx"
"Source/cmLocalUnixMakefileGenerator3.cxx"
"Source/cmExecProgramCommand.cxx"
@@ -218,22 +220,6 @@ and workspaces that can be used in the compiler environment of your choice.")
(search-paths
(package-native-search-paths cmake-minimal))))
-(define-public cmake-3.15.5
- ;; CMake 3.15.5 fixes some issues, but declare another version to
- ;; avoid triggering the rebuild of all CMake-based packages.
- ;; See <https://issues.guix.gnu.org/issue/38060>.
- (package
- (inherit cmake)
- (version "3.15.5")
- (source (origin
- (inherit (package-source cmake))
- (uri (string-append "https://www.cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (sha256
- (base32
- "1d5y8d92axcc6rfqlsxamayfs3fc1vdby91hn5mx1kn02ppprpgv"))))))
-
(define-public emacs-cmake-mode
(package
(inherit cmake)
diff --git a/gnu/packages/patches/cmake-curl-certificates.patch b/gnu/packages/patches/cmake-curl-certificates.patch
index 36252083f8..7fe2615271 100644
--- a/gnu/packages/patches/cmake-curl-certificates.patch
+++ b/gnu/packages/patches/cmake-curl-certificates.patch
@@ -6,19 +6,19 @@ as well as /etc/ssl/certs.
--- cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:27:36.926907260 +0200
+++ cmake-3.13.1/Source/cmCurl.cxx 2019-09-10 17:52:35.475903919 +0200
-@@ -4,11 +4,8 @@
-
- #include "cmThirdParty.h"
+@@ -2,11 +2,8 @@
+ file Copyright.txt or https://cmake.org/licensing for details. */
+ #include "cmCurl.h"
-#if !defined(CMAKE_USE_SYSTEM_CURL) && !defined(_WIN32) && \
- !defined(__APPLE__) && !defined(CURL_CA_BUNDLE) && !defined(CURL_CA_PATH)
# define CMAKE_FIND_CAFILE
# include "cmSystemTools.h"
-#endif
+ #include "cmStringAlgorithms.h"
// curl versions before 7.21.5 did not provide this error code
- #if defined(LIBCURL_VERSION_NUM) && LIBCURL_VERSION_NUM < 0x071505
-@@ -29,6 +26,19 @@ std::string cmCurlSetCAInfo(::CURL* curl
+@@ -30,6 +27,19 @@
::CURLcode res = ::curl_easy_setopt(curl, CURLOPT_CAINFO, cafile);
check_curl_result(res, "Unable to set TLS/SSL Verify CAINFO: ");
}