summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-05 11:31:34 -0500
committerLeo Famulari <leo@famulari.name>2017-01-05 11:32:44 -0500
commit92e779592d269ca1924f184496eb4ca832997b12 (patch)
tree7a31fffa39a14d11fdeb6c13a85e1559b6b2c313 /gnu/packages/autotools.scm
parent78c172a56ef22b3145b9e8e78816a9607cb01b9b (diff)
downloadguix-patches-92e779592d269ca1924f184496eb4ca832997b12.tar
guix-patches-92e779592d269ca1924f184496eb4ca832997b12.tar.gz
gnu: libtool: Correct replacement shebang.
* gnu/packages/autotools.scm (libtool)[arguments]: Correct replacement shebang in 'restore-ltmain-shebang' phase.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index a2c1f3dd2e..442c87c1f1 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -334,7 +334,7 @@ Makefile, simplifying the entire process for the developer.")
(add-after 'patch-source-shebangs 'restore-ltmain-shebang
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "build-aux/ltmain.in"
- (("^#!.*/bin/sh$") "/bin/sh"))
+ (("^#!.*/bin/sh$") "#!/bin/sh"))
#t)))))
(synopsis "Generic shared library support tools")