summaryrefslogtreecommitdiff
path: root/gnu/packages/autotools.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-05 10:44:43 -0500
committerLeo Famulari <leo@famulari.name>2017-01-05 10:46:34 -0500
commit78c172a56ef22b3145b9e8e78816a9607cb01b9b (patch)
tree2eaf782ed3abea2f4ac1e8e295074d8cba60288c /gnu/packages/autotools.scm
parentc5862bda95e3171c1addf6ff198a953bcda785b4 (diff)
downloadguix-patches-78c172a56ef22b3145b9e8e78816a9607cb01b9b.tar
guix-patches-78c172a56ef22b3145b9e8e78816a9607cb01b9b.tar.gz
gnu: libtool: Make sure all phases return a successful value.
* gnu/packages/autotools.scm (libtool)[arguments]: Return #t from 'pre-check' and 'restore-ltmain-shebang' phases.
Diffstat (limited to 'gnu/packages/autotools.scm')
-rw-r--r--gnu/packages/autotools.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 8ff7b8cf6d..a2c1f3dd2e 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -329,11 +329,13 @@ Makefile, simplifying the entire process for the developer.")
(let ((bash (assoc-ref inputs "bash")))
(substitute* "tests/testsuite"
(("/bin/sh")
- (string-append bash "/bin/sh"))))))
+ (string-append bash "/bin/sh")))
+ #t)))
(add-after 'patch-source-shebangs 'restore-ltmain-shebang
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "build-aux/ltmain.in"
- (("^#!.*/bin/sh$") "/bin/sh")))))))
+ (("^#!.*/bin/sh$") "/bin/sh"))
+ #t)))))
(synopsis "Generic shared library support tools")
(description