summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b33fb3a4c..a5c2e60ce4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13529,9 +13529,9 @@ English stemmer.")
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))
- (setenv "PYCONFIG" (string-append (or (which "python3-config")
- (which "python-config"))
- " --embed"))
+ (setenv "PYCONFIG" (if (which "python3-config")
+ "python3-config --embed"
+ "python-config"))
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway