summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-07-30 09:32:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-30 12:09:47 +0200
commit39386de24439c81f1a7c683ae8c5dd1c5f24e09e (patch)
tree10aec2a3d701f1388b599d75ceb7daa8b28773b2 /gnu
parentde681bdb1148b31c1457bb6c1a59067aa47cc9fd (diff)
downloadguix-patches-39386de24439c81f1a7c683ae8c5dd1c5f24e09e.tar
guix-patches-39386de24439c81f1a7c683ae8c5dd1c5f24e09e.tar.gz
gnu: python2-setproctitle: Fix build.
* gnu/packages/python-xyz.scm (python2-setproctitle): Don't pass ‘--embed’ to python-config. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b33fb3a4c..a5c2e60ce4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13529,9 +13529,9 @@ English stemmer.")
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))
- (setenv "PYCONFIG" (string-append (or (which "python3-config")
- (which "python-config"))
- " --embed"))
+ (setenv "PYCONFIG" (if (which "python3-config")
+ "python3-config --embed"
+ "python-config"))
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway