summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm42
1 files changed, 3 insertions, 39 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index cd40ce3744..22083940c4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -721,42 +721,6 @@ programmer to write text-based user interfaces.")
(home-page "https://github.com/nsf/termbox-go")
(license license:expat))))
-(define-public go-golang.org-x-crypto-ssh-terminal
- (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
- (revision "0"))
- (package
- (name "go-golang.org-x-crypto-ssh-terminal")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/crypto")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/crypto/ssh/terminal"
- #:unpack-path "golang.org/x/crypto"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files
- (string-append (assoc-ref outputs "out")
- "/src/golang.org/x/crypto/ed25519/testdata")
- ".*\\.gz$"))
- #t)))))
- (synopsis "Support functions for dealing with terminals in Go")
- (description "@code{terminal} provides support functions for dealing
-with terminals in Go.")
- (home-page "https://go.googlesource.com/crypto/")
- (license license:bsd-3))))
-
(define-public go-github-com-junegunn-fzf
(package
(name "go-github-com-junegunn-fzf")
@@ -779,7 +743,7 @@ with terminals in Go.")
("go-github-com-mattn-go-shellwords" ,go-github-com-mattn-go-shellwords)
("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
("go-github-com-gdamore-tcell" ,go-github-com-gdamore-tcell)
- ("go-golang-org-x-crypto-ssh-terminal" ,go-golang-org-x-crypto-ssh-terminal)))
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
(home-page "https://github.com/junegunn/fzf")
(synopsis "Command-line fuzzy-finder")
(description "This package provides an interactive command-line filter
@@ -805,8 +769,8 @@ usable with any list--including files, command history, processes and more.")
(arguments
'(#:import-path "github.com/howeyc/gopass"))
(propagated-inputs
- `(("go-golang.org-x-crypto-ssh-terminal"
- ,go-golang.org-x-crypto-ssh-terminal)))
+ `(("go-golang-org-x-crypto"
+ ,go-golang-org-x-crypto)))
(synopsis "Retrieve password from a terminal or piped input in Go")
(description
"@code{gopass} is a Go package for retrieving a password from user