summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-08-14 14:42:50 -0400
committerLeo Famulari <leo@famulari.name>2019-10-29 11:03:12 -0400
commit561d391ba8711049fea8eca25a1685b2a051b55c (patch)
tree656cb544b8f23b124509d81af4db8d46fcd2230d /gnu/packages/terminals.scm
parentb98b3674ee1556db6c5f62fc377eebceb14ae5ad (diff)
downloadguix-patches-561d391ba8711049fea8eca25a1685b2a051b55c.tar
guix-patches-561d391ba8711049fea8eca25a1685b2a051b55c.tar.gz
gnu: Go standard library 'x' packages: Consolidate.
* gnu/packages/golang.scm (go-golang-org-x-text, go-golang-org-x-sys, go-golang-org-x-net, go-golang-org-x-time): New variables. (go-golang.org-x-crypto-ssh-terminal, go-golang-org-x-crypto-bcrypt, go-golang-org-x-crypto-blowfish, go-golang-org-x-crypto-pbkdf2, go-golang-org-x-crypto-tea, go-golang-org-x-crypto-salsa20, go-golang-org-x-crypto-cast5, go-golang-org-x-crypto-twofish, go-golang-org-x-crypto-xtea, go-golang-org-x-crypto-ed25519, go-golang-org-x-crypto-ripemd160, go-golang-org-x-crypto-blake2s, go-golang-org-x-crypto-sha3, go-golang-org-x-text-encoding, go-golang-org-x-text-transform, go-golang-org-x-text-unicode-norm, go-golang-org-x-net-ipv4, go-golang-org-x-net-bpf, go-golang-org-x-net-context, go-golang-org-x-net-internal-socks, go-golang-org-x-net-internal-socket, go-golang-org-x-net-internal-iana, go-golang-org-x-net-ipv6, go-golang-org-x-net-proxy, go-golang-org-x-sys-cpu, go-golang-org-x-sys-unix, go-golang-org-x-time-rate): Remove variables. (go-github-com-sirupsen-logrus, go-github-com-docker-distribution, go-github-com-libp2p-go-libp2p-crypto, go-github-com-multiformats-go-multihash, go-github-com-libp2p-go-libp2p-peer, go-github-com-libp2p-go-libp2p-metrics, go-github-com-multiformats-go-multiaddr, go-github-com-multiformats-go-multiaddr-net, go-github-com-mattn-go-isatty, go-github-com-gdamore-encoding, go-github-com-gdamore-tcell): Adjust accordingly. * gnu/packages/docker.scm (docker-libnetwork-cmd-proxy): Likewise. * gnu/packages/databases.scm (mongo-tools): Likewise. * gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipfs-api, gx, gx-go): Likewise. * gnu/packages/web.scm (poussetaches): Likewise. * gnu/packages/terminals.scm (go-github-com-junegunn-fzf, go-github.com-howeyc-gopass): Likewise. (go-golang.org-x-crypto-ssh-terminal): Remove variable. * gnu/packages/syncthing.scm (syncthing, go-github-com-oschwald-geoip2-golang, go-github-com-oschwald-maxminddb-golang, go-github-com-syncthing-notify): Adjust accordingly. * gnu/packages/linux.scm (go-netlink): Likewise.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm42
1 files changed, 3 insertions, 39 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index cd40ce3744..22083940c4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -721,42 +721,6 @@ programmer to write text-based user interfaces.")
(home-page "https://github.com/nsf/termbox-go")
(license license:expat))))
-(define-public go-golang.org-x-crypto-ssh-terminal
- (let ((commit "c78caca803c95773f48a844d3dcab04b9bc4d6dd")
- (revision "0"))
- (package
- (name "go-golang.org-x-crypto-ssh-terminal")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/crypto")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vxlfxr9y681yn2cfh6dbqmq35vvq4f45ay0mm31ffkny9cms0y4"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "golang.org/x/crypto/ssh/terminal"
- #:unpack-path "golang.org/x/crypto"
- #:phases
- (modify-phases %standard-phases
- (add-before 'reset-gzip-timestamps 'make-gzip-archive-writable
- (lambda* (#:key outputs #:allow-other-keys)
- (map (lambda (file)
- (make-file-writable file))
- (find-files
- (string-append (assoc-ref outputs "out")
- "/src/golang.org/x/crypto/ed25519/testdata")
- ".*\\.gz$"))
- #t)))))
- (synopsis "Support functions for dealing with terminals in Go")
- (description "@code{terminal} provides support functions for dealing
-with terminals in Go.")
- (home-page "https://go.googlesource.com/crypto/")
- (license license:bsd-3))))
-
(define-public go-github-com-junegunn-fzf
(package
(name "go-github-com-junegunn-fzf")
@@ -779,7 +743,7 @@ with terminals in Go.")
("go-github-com-mattn-go-shellwords" ,go-github-com-mattn-go-shellwords)
("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)
("go-github-com-gdamore-tcell" ,go-github-com-gdamore-tcell)
- ("go-golang-org-x-crypto-ssh-terminal" ,go-golang-org-x-crypto-ssh-terminal)))
+ ("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
(home-page "https://github.com/junegunn/fzf")
(synopsis "Command-line fuzzy-finder")
(description "This package provides an interactive command-line filter
@@ -805,8 +769,8 @@ usable with any list--including files, command history, processes and more.")
(arguments
'(#:import-path "github.com/howeyc/gopass"))
(propagated-inputs
- `(("go-golang.org-x-crypto-ssh-terminal"
- ,go-golang.org-x-crypto-ssh-terminal)))
+ `(("go-golang-org-x-crypto"
+ ,go-golang-org-x-crypto)))
(synopsis "Retrieve password from a terminal or piped input in Go")
(description
"@code{gopass} is a Go package for retrieving a password from user