summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eeca90641c..4b84594b2a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1285,8 +1285,12 @@ WebSocket usage in Python programs.")
(sha256
(base32
"13jr0wkj9c2j8c0c8iaal9iivi0bpxghnsdn6lxcpnmc657q4ajh"))))
- ;; TODO: unbundle urllib3 and chardet.
(build-system python-build-system)
+ (propagated-inputs
+ `(("python-certifi" ,python-certifi)
+ ("python-chardet" ,python-chardet)
+ ("python-idna" ,python-idna)
+ ("python-urllib3" ,python-urllib3)))
(arguments
;; FIXME: Some tests require network access.
'(#:tests? #f))
@@ -1455,11 +1459,6 @@ authenticated session objects providing things like keep-alive.")
"08lwd9f3hqznyf32vnzwvp87pchx062nkbgyrf67rwlkgj0jk5fy"))))
(build-system python-build-system)
(arguments `(#:tests? #f))
- (native-inputs
- `(;; some packages for tests
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-tornado" ,python-tornado)))
(propagated-inputs
`(;; These 5 inputs are used to build urrlib3[secure]
("python-certifi" ,python-certifi)