summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-01 16:29:27 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-01 16:29:27 +0100
commit85ef07c4b278200db7c396f4021146916588f2fb (patch)
treef9d8dcd9886c35d4156f2895e56396ff69d46cf1 /gnu/packages/python-web.scm
parent95dc93da8549381c3adbff31992d689836803137 (diff)
downloadguix-patches-85ef07c4b278200db7c396f4021146916588f2fb.tar
guix-patches-85ef07c4b278200db7c396f4021146916588f2fb.tar.gz
gnu: python-requests: Propagate required inputs.
This is a follow-up to commit b5c2e7205177742f33b308a1590f279ce132d5b4. * gnu/packages/python-web.scm (python-requests)[propagated-inputs]: Add PYTHON-CERTIFI, PYTHON-CHARDET, PYTHON-IDNA, and PYTHON-URLLIB3. (python-urllib3)[native-inputs]: Remove (due to dependency cycle).
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eeca90641c..4b84594b2a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1285,8 +1285,12 @@ WebSocket usage in Python programs.")
(sha256
(base32
"13jr0wkj9c2j8c0c8iaal9iivi0bpxghnsdn6lxcpnmc657q4ajh"))))
- ;; TODO: unbundle urllib3 and chardet.
(build-system python-build-system)
+ (propagated-inputs
+ `(("python-certifi" ,python-certifi)
+ ("python-chardet" ,python-chardet)
+ ("python-idna" ,python-idna)
+ ("python-urllib3" ,python-urllib3)))
(arguments
;; FIXME: Some tests require network access.
'(#:tests? #f))
@@ -1455,11 +1459,6 @@ authenticated session objects providing things like keep-alive.")
"08lwd9f3hqznyf32vnzwvp87pchx062nkbgyrf67rwlkgj0jk5fy"))))
(build-system python-build-system)
(arguments `(#:tests? #f))
- (native-inputs
- `(;; some packages for tests
- ("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
- ("python-tornado" ,python-tornado)))
(propagated-inputs
`(;; These 5 inputs are used to build urrlib3[secure]
("python-certifi" ,python-certifi)