summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f872eb8de8..be7bf43646 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -54,7 +54,9 @@
(replace 'configure
(lambda _
(setenv "LSOF_CC" ,(cc-for-target))
- (setenv "LINUX_CONF_CC" "gcc")
+ ,@(if (%current-target-system)
+ (list (setenv "LINUX_CONF_CC" "gcc"))
+ '())
(setenv "LSOF_MAKE" "make")
;; By default, the makefile captures the output of 'uname -a'.