summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-03-30 14:40:04 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-03-30 14:40:04 +0200
commit643d05eb205294ecc3a48b1426bdd549e8ed3298 (patch)
treed8e908da970ca0d9b5b216cc421aa7f59f949fac /gnu/packages/lsof.scm
parent2387adf60022799a8af144ed8dd2b7a46c155374 (diff)
downloadguix-patches-643d05eb205294ecc3a48b1426bdd549e8ed3298.tar
guix-patches-643d05eb205294ecc3a48b1426bdd549e8ed3298.tar.gz
lsof: Prevent mass-rebuild.
* gnu/packages/lsof.scm (lsof): Set LINUX_CONF_CC variable only when cross-compiling.
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index f872eb8de8..be7bf43646 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -54,7 +54,9 @@
(replace 'configure
(lambda _
(setenv "LSOF_CC" ,(cc-for-target))
- (setenv "LINUX_CONF_CC" "gcc")
+ ,@(if (%current-target-system)
+ (list (setenv "LINUX_CONF_CC" "gcc"))
+ '())
(setenv "LSOF_MAKE" "make")
;; By default, the makefile captures the output of 'uname -a'.