summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index b3a5cd915e..d807315906 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,6 +170,22 @@ resolution, asynchronous file system operations, and threading primitives.")
(home-page "https://github.com/JuliaLang/libuv")
(properties '((hidden? . #t))))))
+(define-public libuv-for-luv
+ ;; When upgrading make-lua-luv, also upgrade this. Get the version from
+ ;; https://github.com/luvit/luv/blob/master/CMakeLists.txt
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.43.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "194kwq3jfj9s628kzkchdca534rikjw0xiyas0cjbphqmsvjpmwh"))))
+ (properties '((hidden? . #t)))))
+
(define-public perl-anyevent
(package
(name "perl-anyevent")