summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorLuis Henrique Gomes Higino <luishenriquegh2701@gmail.com>2022-05-18 10:32:22 -0300
committerLudovic Courtès <ludo@gnu.org>2022-05-18 22:29:55 +0200
commit42772a2fa7bba87168d8e9e6803d3152b4899acd (patch)
treea326b1d14699877d127cc60c9cdcb45d7d828b2c /gnu/packages/libevent.scm
parent32916e04f7e1729b7ea5ab768607eb08183c015d (diff)
downloadguix-patches-42772a2fa7bba87168d8e9e6803d3152b4899acd.tar
guix-patches-42772a2fa7bba87168d8e9e6803d3152b4899acd.tar.gz
gnu: lua-luv: Update to 1.43.0-0.
* gnu/packages/libevent.scm (libuv-for-luv): New variable * gnu/packages/lua.scm (lua-luv): Update to 1.43.0-0. [inputs]: Change libuv to libuv-for-luv. [native-inputs]: Update lua-compat-5.3 to 0.10. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index b3a5cd915e..d807315906 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,6 +170,22 @@ resolution, asynchronous file system operations, and threading primitives.")
(home-page "https://github.com/JuliaLang/libuv")
(properties '((hidden? . #t))))))
+(define-public libuv-for-luv
+ ;; When upgrading make-lua-luv, also upgrade this. Get the version from
+ ;; https://github.com/luvit/luv/blob/master/CMakeLists.txt
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.43.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "194kwq3jfj9s628kzkchdca534rikjw0xiyas0cjbphqmsvjpmwh"))))
+ (properties '((hidden? . #t)))))
+
(define-public perl-anyevent
(package
(name "perl-anyevent")