summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9b0264e889..ef304dd0df 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3067,12 +3067,12 @@ to easily extend the contacts collection.")
(add-after 'unpack 'fix-paths-for-test
;; This test tries to access paths like /home, /usr/bin and /bin/ls
;; which don't exist in the build-container. Change to existing paths.
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "autotests/runnercontexttest.cpp"
(("/home\"") "/tmp\"") ;; single path-part
(("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
(("/bin/ls")
- (search-input-file %build-inputs "/bin/ls")))))
+ (search-input-file inputs "/bin/ls")))))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))