summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-27 11:46:46 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-27 11:48:17 +0100
commit1b8a18b629dcde9b6288fbce4d130b51dfb69143 (patch)
tree1720f538a5d6035f82f00f67805399d638db72ec /gnu/packages/kde-frameworks.scm
parent9204408de706e1304428b6817fad69395834ad37 (diff)
downloadguix-patches-1b8a18b629dcde9b6288fbce4d130b51dfb69143.tar
guix-patches-1b8a18b629dcde9b6288fbce4d130b51dfb69143.tar.gz
gnu: krunner: Remove reference to '%build-inputs'.
* gnu/packages/kde-frameworks.scm (krunner)[arguments]: Replace reference to '%build-inputs' by 'inputs' keyword argument.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 9b0264e889..ef304dd0df 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3067,12 +3067,12 @@ to easily extend the contacts collection.")
(add-after 'unpack 'fix-paths-for-test
;; This test tries to access paths like /home, /usr/bin and /bin/ls
;; which don't exist in the build-container. Change to existing paths.
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "autotests/runnercontexttest.cpp"
(("/home\"") "/tmp\"") ;; single path-part
(("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
(("/bin/ls")
- (search-input-file %build-inputs "/bin/ls")))))
+ (search-input-file inputs "/bin/ls")))))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))