summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 904597a506..5f4d0351cb 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -401,6 +401,46 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
(description "This package provides a wrapper for the lame audio encoder.")
(license license:expat)))
+(define-public julia-libass-jll
+ (package
+ (name "julia-libass-jll")
+ (version "0.14.0+2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/libass_jll.jl")
+ (commit (string-append "libass-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05nvis5ifmaq1g0c98hcpnl0ky22qgp64d4lb6g6r4yrrn6kqlsc"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"libass\"")
+ (string-append "\"" (assoc-ref inputs "libass") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libass" ,libass)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-freetype2-jll" ,julia-freetype2-jll)
+ ("julia-fribidi-jll" ,julia-fribidi-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/libass_jll.jl")
+ (synopsis "Libass library wrappers")
+ (description "This package provides a wrapper for libass.")
+ (license license:expat)))
+
(define-public julia-libfdk-aac-jll
(package
(name "julia-libfdk-aac-jll")