summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 11:17:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:51 +0300
commitf711bb110b1ba1f25d73ecccaa4cfd27e555e2c7 (patch)
tree893c185beb7e5f7fd50707fccc08e0c77ceea9e6 /gnu/packages/julia-jll.scm
parentafff06e4cee2c4a40ddf8d3c072643b359e600d7 (diff)
downloadguix-patches-f711bb110b1ba1f25d73ecccaa4cfd27e555e2c7.tar
guix-patches-f711bb110b1ba1f25d73ecccaa4cfd27e555e2c7.tar.gz
gnu: Add julia-libass-jll.
* gnu/packages/julia-jll.scm (julia-libass-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 904597a506..5f4d0351cb 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -401,6 +401,46 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
(description "This package provides a wrapper for the lame audio encoder.")
(license license:expat)))
+(define-public julia-libass-jll
+ (package
+ (name "julia-libass-jll")
+ (version "0.14.0+2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/libass_jll.jl")
+ (commit (string-append "libass-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05nvis5ifmaq1g0c98hcpnl0ky22qgp64d4lb6g6r4yrrn6kqlsc"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"libass\"")
+ (string-append "\"" (assoc-ref inputs "libass") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libass" ,libass)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-bzip2-jll" ,julia-bzip2-jll)
+ ("julia-freetype2-jll" ,julia-freetype2-jll)
+ ("julia-fribidi-jll" ,julia-fribidi-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/libass_jll.jl")
+ (synopsis "Libass library wrappers")
+ (description "This package provides a wrapper for libass.")
+ (license license:expat)))
+
(define-public julia-libfdk-aac-jll
(package
(name "julia-libfdk-aac-jll")