summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7e83c7ea4e..db04b93f20 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -718,15 +718,17 @@ more.")
(define-public cgal
(package
(name "cgal")
- (version "4.14.2")
+ (version "5.2")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/CGAL/cgal/releases/download/releases/"
- "CGAL-" version "/CGAL-" version ".tar.xz"))
+ "https://github.com/CGAL/cgal/releases/download/v" version
+ "/CGAL-" version ".tar.xz"))
(sha256
(base32
- "08lrp3hfwdypggz4138bnkh6bjxn441zg2y9xnq5mrjfc5ini6w1"))))
+ "08sr2k2dm4zasfbvisqpvs6djqw3rywzwpzr701an870nvnqck3l"))
+ (patches (search-patches "cgal-security-pr-5371.patch"))
+ (patch-flags '("-p2"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no test target