summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-03-05 23:31:15 +0100
committerLéo Le Bouter <lle-bout@zaclys.net>2021-03-05 23:51:57 +0100
commitfc193b6518ad8df0cc92cb50b88217430dea47e3 (patch)
tree085dc905731114da5b186ecde31d0869d89f510f /gnu/packages/graphics.scm
parenta714af38d5d1046081524d859cde4cd8fd12a923 (diff)
downloadguix-patches-fc193b6518ad8df0cc92cb50b88217430dea47e3.tar
guix-patches-fc193b6518ad8df0cc92cb50b88217430dea47e3.tar.gz
gnu: cgal: Update to 5.2 [security fixes].
* gnu/packages/patches/cgal-security-pr-5371.patch: New patch. Downloaded from <https://patch-diff.githubusercontent.com/raw/CGAL/cgal/pull/5371.patch>, with hunks on files matching pattern "*Convex_decomposition_3*" removed because they don't exist in cgal's released sources. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/graphics.scm (cgal): Update to 5.2. [source]: Apply patch.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 7e83c7ea4e..db04b93f20 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -718,15 +718,17 @@ more.")
(define-public cgal
(package
(name "cgal")
- (version "4.14.2")
+ (version "5.2")
(source (origin
(method url-fetch)
(uri (string-append
- "https://github.com/CGAL/cgal/releases/download/releases/"
- "CGAL-" version "/CGAL-" version ".tar.xz"))
+ "https://github.com/CGAL/cgal/releases/download/v" version
+ "/CGAL-" version ".tar.xz"))
(sha256
(base32
- "08lrp3hfwdypggz4138bnkh6bjxn441zg2y9xnq5mrjfc5ini6w1"))))
+ "08sr2k2dm4zasfbvisqpvs6djqw3rywzwpzr701an870nvnqck3l"))
+ (patches (search-patches "cgal-security-pr-5371.patch"))
+ (patch-flags '("-p2"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; no test target