summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 79fd134bbe..c3c1a4a580 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -709,17 +709,16 @@ and understanding different BRDFs (and other component functions).")
"--disable-examples")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autoreconf
+ (replace 'bootstrap
(lambda _
;; let's call configure from configure phase and not now
(substitute* "autogen.sh" (("./configure") "# ./configure"))
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("libtool" ,libtool)
("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bash" ,bash)))
+ ("automake" ,automake)))
(inputs
`(("libx11" ,libx11)
("freetype" ,freetype)