summaryrefslogtreecommitdiff
path: root/gnu/packages/graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-10-09 10:32:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-10-09 10:33:07 +0300
commit8d18edde755f4bf5b4723fc9ce89e1cd831d2b7b (patch)
treea1e1d578769dda8c67c68c5f9be4ef9e988a24a8 /gnu/packages/graphics.scm
parent31f45cf7be18d1cfc46a0ae785a3057227c4b185 (diff)
downloadguix-patches-8d18edde755f4bf5b4723fc9ce89e1cd831d2b7b.tar
guix-patches-8d18edde755f4bf5b4723fc9ce89e1cd831d2b7b.tar.gz
* gnu: agg: Replace bootstrap phase.
* gnu/packages/graphics.scm (agg)[arguments]: Remove custom 'autoreconf phase and replace default 'bootstrap phase. Use INVOKE. [native-inputs]: Remove bash.
Diffstat (limited to 'gnu/packages/graphics.scm')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 79fd134bbe..c3c1a4a580 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -709,17 +709,16 @@ and understanding different BRDFs (and other component functions).")
"--disable-examples")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autoreconf
+ (replace 'bootstrap
(lambda _
;; let's call configure from configure phase and not now
(substitute* "autogen.sh" (("./configure") "# ./configure"))
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("libtool" ,libtool)
("autoconf" ,autoconf)
- ("automake" ,automake)
- ("bash" ,bash)))
+ ("automake" ,automake)))
(inputs
`(("libx11" ,libx11)
("freetype" ,freetype)