summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f8cdf94eaa..5c8852c4ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7088,7 +7088,7 @@ properties, screen resolution, and other GNOME parameters.")
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "3.32.2")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7096,8 +7096,9 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0anlkdnqsp5fqvmg95rqjpp1ifcx5xzsvwcrdsvb1cqzbh6inmp5"))
- (patches (search-patches "gnome-shell-theme.patch"))
+ "0k9vq2gh1nhdd6fpp7jnwx37qxaakawiqw1xnlfjvq5g5zdn8ckh"))
+ (patches (search-patches "gnome-shell-theme.patch"
+ "gnome-shell-disable-test.patch"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -7191,7 +7192,8 @@ properties, screen resolution, and other GNOME parameters.")
'("inkscape" "intltool" "glib:bin"))
#:outputs outputs)))))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ `(("asciidoc" ,asciidoc)
+ ("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("gobject-introspection" ,gobject-introspection)
("inkscape" ,inkscape)
@@ -7212,6 +7214,7 @@ properties, screen resolution, and other GNOME parameters.")
("gdm" ,gdm)
("gdk-pixbuf" ,gdk-pixbuf+svg)
("gjs" ,gjs)
+ ("gnome-autoar" ,gnome-autoar)
("gnome-bluetooth" ,gnome-bluetooth)
("gnome-desktop" ,gnome-desktop)
("gnome-settings-daemon" ,gnome-settings-daemon)