summaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-12-21 23:21:51 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-04-18 16:51:29 -0400
commit28457ae6fe3302d426e03c9ebd4b9d187470a946 (patch)
tree9e86978ad18fbddb5acc161644feb95ea3935a32 /gnu/packages/gnome.scm
parent76e1830c03c3d1cff64795c65aa7e660a79a909c (diff)
downloadguix-patches-28457ae6fe3302d426e03c9ebd4b9d187470a946.tar
guix-patches-28457ae6fe3302d426e03c9ebd4b9d187470a946.tar.gz
gnu: gnome-shell: Update to 3.34.2.
* gnu/packages/gnome.scm (gnome-shell): Update to 3.34.2. [source]: Add patch. [native-inputs]: Add asciidoc. [inputs]: Add gnome-autoar. * gnu/packages/patches/gnome-shell-theme.patch: Adjust patch accordingly. * gnu/packages/patches/gnome-shell-disable-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. (cherry picked from commit 4ac325aa9bf8dd237f5b5be7a1523d957be0067f)
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f8cdf94eaa..5c8852c4ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7088,7 +7088,7 @@ properties, screen resolution, and other GNOME parameters.")
(define-public gnome-shell
(package
(name "gnome-shell")
- (version "3.32.2")
+ (version "3.34.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -7096,8 +7096,9 @@ properties, screen resolution, and other GNOME parameters.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0anlkdnqsp5fqvmg95rqjpp1ifcx5xzsvwcrdsvb1cqzbh6inmp5"))
- (patches (search-patches "gnome-shell-theme.patch"))
+ "0k9vq2gh1nhdd6fpp7jnwx37qxaakawiqw1xnlfjvq5g5zdn8ckh"))
+ (patches (search-patches "gnome-shell-theme.patch"
+ "gnome-shell-disable-test.patch"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -7191,7 +7192,8 @@ properties, screen resolution, and other GNOME parameters.")
'("inkscape" "intltool" "glib:bin"))
#:outputs outputs)))))))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
+ `(("asciidoc" ,asciidoc)
+ ("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
("gobject-introspection" ,gobject-introspection)
("inkscape" ,inkscape)
@@ -7212,6 +7214,7 @@ properties, screen resolution, and other GNOME parameters.")
("gdm" ,gdm)
("gdk-pixbuf" ,gdk-pixbuf+svg)
("gjs" ,gjs)
+ ("gnome-autoar" ,gnome-autoar)
("gnome-bluetooth" ,gnome-bluetooth)
("gnome-desktop" ,gnome-desktop)
("gnome-settings-daemon" ,gnome-settings-daemon)