summaryrefslogtreecommitdiff
path: root/gnu/packages/apr.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/apr.scm')
-rw-r--r--gnu/packages/apr.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 62af24f0c7..8ccec08fa2 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,11 +87,10 @@ around or take advantage of platform-specific deficiencies or features.")
(apr (assoc-ref inputs "apr"))
(expat (assoc-ref inputs "expat")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-apr=" apr)
- (string-append "--with-expat=" expat)))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-apr=" apr)
+ (string-append "--with-expat=" expat))))))
;; There are race conditions during 'make check'. Typically, the
;; 'testall' executable is not built yet by the time 'make check' tries