summaryrefslogtreecommitdiff
path: root/gnu/packages/apr.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 01:36:49 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:40:08 -0400
commit3d77ecfed4aab76fbd1a4b6718e44f42f482a70b (patch)
treeb531db4f79f2561065bccc06b2c1d0fc1b576650 /gnu/packages/apr.scm
parentab6e5690af614ea2c676d7f05619a247f3cfd766 (diff)
downloadguix-patches-3d77ecfed4aab76fbd1a4b6718e44f42f482a70b.tar
guix-patches-3d77ecfed4aab76fbd1a4b6718e44f42f482a70b.tar.gz
gnu: apr-util: Use invoke.
* gnu/packages/apr.scm (apr-util)[arguments]: Use invoke in the custom configure phase.
Diffstat (limited to 'gnu/packages/apr.scm')
-rw-r--r--gnu/packages/apr.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/apr.scm b/gnu/packages/apr.scm
index 62af24f0c7..8ccec08fa2 100644
--- a/gnu/packages/apr.scm
+++ b/gnu/packages/apr.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -87,11 +87,10 @@ around or take advantage of platform-specific deficiencies or features.")
(apr (assoc-ref inputs "apr"))
(expat (assoc-ref inputs "expat")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-apr=" apr)
- (string-append "--with-expat=" expat)))))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-apr=" apr)
+ (string-append "--with-expat=" expat))))))
;; There are race conditions during 'make check'. Typically, the
;; 'testall' executable is not built yet by the time 'make check' tries