summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-10-02 19:05:02 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-10-09 19:24:19 +0300
commitfee0bced7fec2f9950957976a28f033edd4f877c (patch)
tree1973046ca180f2d3feacfa71eeaf285e4ee7ee84 /guix
parent5e68f7a7b338951dcc227799a51c59d9ac77c696 (diff)
downloadguix-patches-fee0bced7fec2f9950957976a28f033edd4f877c.tar
guix-patches-fee0bced7fec2f9950957976a28f033edd4f877c.tar.gz
home: services: configuration: Support file-like objects.
* gnu/home/services/configuration.scm (interpose): Operate only with file-like objects. (string-or-gexp?): Delete procedure. (serialize-string-or-gexp): Rename to 'serialize-file-like'. (text-config?): Call 'file-like' intead of 'string-or-gexp?'. * guix/scripts/home/import.scm: (generate-bash-module+configuration): Don't call slurp-file-gexp. * gnu/home/services/configuration.scm: Move content ... * gnu/services/configuration.scm: here. * gnu/home/services/shells.scm: Delete (gnu home services configuration). * gnu/home/services/xdg.scm: Same. * gnu/local.mk: Same. * tests/guix-home.sh: Test home-bash-service-type and extension with home-bash-extension.
Diffstat (limited to 'guix')
-rw-r--r--guix/scripts/home/import.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/guix/scripts/home/import.scm b/guix/scripts/home/import.scm
index c977ec3861..611f580e85 100644
--- a/guix/scripts/home/import.scm
+++ b/guix/scripts/home/import.scm
@@ -46,17 +46,15 @@
(home-bash-configuration
,@(if (file-exists? rc)
`((bashrc
- (list (slurp-file-gexp (local-file ,rc)))))
+ (list (local-file ,rc))))
'())
,@(if (file-exists? profile)
`((bash-profile
- (list (slurp-file-gexp
- (local-file ,profile)))))
+ (list (local-file ,profile))))
'())
,@(if (file-exists? logout)
`((bash-logout
- (list (slurp-file-gexp
- (local-file ,logout)))))
+ (list (local-file ,logout))))
'()))))))