summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-10-02 19:05:02 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-10-09 19:24:19 +0300
commitfee0bced7fec2f9950957976a28f033edd4f877c (patch)
tree1973046ca180f2d3feacfa71eeaf285e4ee7ee84
parent5e68f7a7b338951dcc227799a51c59d9ac77c696 (diff)
downloadguix-patches-fee0bced7fec2f9950957976a28f033edd4f877c.tar
guix-patches-fee0bced7fec2f9950957976a28f033edd4f877c.tar.gz
home: services: configuration: Support file-like objects.
* gnu/home/services/configuration.scm (interpose): Operate only with file-like objects. (string-or-gexp?): Delete procedure. (serialize-string-or-gexp): Rename to 'serialize-file-like'. (text-config?): Call 'file-like' intead of 'string-or-gexp?'. * guix/scripts/home/import.scm: (generate-bash-module+configuration): Don't call slurp-file-gexp. * gnu/home/services/configuration.scm: Move content ... * gnu/services/configuration.scm: here. * gnu/home/services/shells.scm: Delete (gnu home services configuration). * gnu/home/services/xdg.scm: Same. * gnu/local.mk: Same. * tests/guix-home.sh: Test home-bash-service-type and extension with home-bash-extension.
-rw-r--r--gnu/home/services/configuration.scm109
-rw-r--r--gnu/home/services/shells.scm1
-rw-r--r--gnu/home/services/xdg.scm1
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/services/configuration.scm90
-rw-r--r--guix/scripts/home/import.scm8
-rw-r--r--tests/guix-home.sh27
7 files changed, 117 insertions, 120 deletions
diff --git a/gnu/home/services/configuration.scm b/gnu/home/services/configuration.scm
deleted file mode 100644
index 5e7743e7d6..0000000000
--- a/gnu/home/services/configuration.scm
+++ /dev/null
@@ -1,109 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
-;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu home services configuration)
- #:use-module (gnu services configuration)
- #:use-module (guix gexp)
- #:use-module (srfi srfi-1)
- #:use-module (ice-9 curried-definitions)
- #:use-module (ice-9 match)
- #:use-module (guix i18n)
- #:use-module (guix diagnostics)
-
- #:export (filter-configuration-fields
-
- interpose
- list-of
-
- list-of-strings?
- alist?
- string-or-gexp?
- serialize-string-or-gexp
- text-config?
- serialize-text-config
- generic-serialize-alist-entry
- generic-serialize-alist))
-
-(define* (filter-configuration-fields configuration-fields fields
- #:optional negate?)
- "Retrieve the fields listed in FIELDS from CONFIGURATION-FIELDS.
-If NEGATE? is @code{#t}, retrieve all fields except FIELDS."
- (filter (lambda (field)
- (let ((member? (member (configuration-field-name field) fields)))
- (if (not negate?) member? (not member?))))
- configuration-fields))
-
-
-(define* (interpose ls #:optional (delimiter "\n") (grammar 'infix))
- "Same as @code{string-join}, but without join and string, returns an
-DELIMITER interposed LS. Support 'infix and 'suffix GRAMMAR values."
- (when (not (member grammar '(infix suffix)))
- (raise
- (formatted-message
- (G_ "The GRAMMAR value must be 'infix or 'suffix, but ~a provided.")
- grammar)))
- (fold-right (lambda (e acc)
- (cons e
- (if (and (null? acc) (eq? grammar 'infix))
- acc
- (cons delimiter acc))))
- '() ls))
-
-(define (list-of pred?)
- "Return a procedure that takes a list and check if all the elements of
-the list result in @code{#t} when applying PRED? on them."
- (lambda (x)
- (if (list? x)
- (every pred? x)
- #f)))
-
-
-(define list-of-strings?
- (list-of string?))
-
-(define alist? list?)
-
-(define (string-or-gexp? sg) (or (string? sg) (gexp? sg)))
-(define (serialize-string-or-gexp field-name val) "")
-
-(define (text-config? config)
- (and (list? config) (every string-or-gexp? config)))
-(define (serialize-text-config field-name val)
- #~(string-append #$@(interpose val "\n" 'suffix)))
-
-(define ((generic-serialize-alist-entry serialize-field) entry)
- "Apply the SERIALIZE-FIELD procedure on the field and value of ENTRY."
- (match entry
- ((field . val) (serialize-field field val))))
-
-(define (generic-serialize-alist combine serialize-field fields)
- "Generate a configuration from an association list FIELDS.
-
-SERIALIZE-FIELD is a procedure that takes two arguments, it will be
-applied on the fields and values of FIELDS using the
-@code{generic-serialize-alist-entry} procedure.
-
-COMBINE is a procedure that takes one or more arguments and combines
-all the alist entries into one value, @code{string-append} or
-@code{append} are usually good candidates for this.
-
-See the @code{serialize-alist} procedure in `@code{(gnu home-services
-version-control}' for an example usage.)}"
- (apply combine
- (map (generic-serialize-alist-entry serialize-field) fields)))
diff --git a/gnu/home/services/shells.scm b/gnu/home/services/shells.scm
index 21b250f35d..1cd17b2c32 100644
--- a/gnu/home/services/shells.scm
+++ b/gnu/home/services/shells.scm
@@ -19,7 +19,6 @@
(define-module (gnu home services shells)
#:use-module (gnu services configuration)
- #:use-module (gnu home services configuration)
#:use-module (gnu home services utils)
#:use-module (gnu home services)
#:use-module (gnu packages shells)
diff --git a/gnu/home/services/xdg.scm b/gnu/home/services/xdg.scm
index 453c05ddbf..20fb7f7b40 100644
--- a/gnu/home/services/xdg.scm
+++ b/gnu/home/services/xdg.scm
@@ -19,7 +19,6 @@
(define-module (gnu home services xdg)
#:use-module (gnu services configuration)
- #:use-module (gnu home services configuration)
#:use-module (gnu home services)
#:use-module (gnu packages freedesktop)
#:use-module (gnu home services utils)
diff --git a/gnu/local.mk b/gnu/local.mk
index ff51c500d4..63ef645deb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -77,7 +77,6 @@ GNU_SYSTEM_MODULES = \
%D%/home/services.scm \
%D%/home/services/symlink-manager.scm \
%D%/home/services/fontutils.scm \
- %D%/home/services/configuration.scm \
%D%/home/services/shells.scm \
%D%/home/services/shepherd.scm \
%D%/home/services/mcron.scm \
diff --git a/gnu/services/configuration.scm b/gnu/services/configuration.scm
index df3d3b6f9b..e8c55b6e4d 100644
--- a/gnu/services/configuration.scm
+++ b/gnu/services/configuration.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017, 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,10 +26,12 @@
#:use-module (guix records)
#:use-module (guix gexp)
#:use-module ((guix utils) #:select (source-properties->location))
- #:use-module ((guix diagnostics) #:select (location-file))
+ #:use-module ((guix diagnostics) #:select (formatted-message location-file))
#:use-module ((guix modules) #:select (file-name->module-name))
+ #:use-module (guix i18n)
#:autoload (texinfo) (texi-fragment->stexi)
#:autoload (texinfo serialize) (stexi->texi)
+ #:use-module (ice-9 curried-definitions)
#:use-module (ice-9 match)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-34)
@@ -56,7 +59,20 @@
generate-documentation
configuration->documentation
empty-serializer
- serialize-package))
+ serialize-package
+
+ filter-configuration-fields
+
+ interpose
+ list-of
+
+ list-of-strings?
+ alist?
+ serialize-file-like
+ text-config?
+ serialize-text-config
+ generic-serialize-alist-entry
+ generic-serialize-alist))
;;; Commentary:
;;;
@@ -323,3 +339,73 @@ Texinfo documentation of its fields."
'-fields))))
(display (generate-documentation `((,configuration-symbol ,fields-getter))
configuration-symbol))))
+
+(define* (filter-configuration-fields configuration-fields fields
+ #:optional negate?)
+ "Retrieve the fields listed in FIELDS from CONFIGURATION-FIELDS.
+If NEGATE? is @code{#t}, retrieve all fields except FIELDS."
+ (filter (lambda (field)
+ (let ((member? (member (configuration-field-name field) fields)))
+ (if (not negate?) member? (not member?))))
+ configuration-fields))
+
+
+(define* (interpose ls #:optional (delimiter "\n") (grammar 'infix))
+ "Same as @code{string-join}, but without join and string, returns an
+DELIMITER interposed LS. Support 'infix and 'suffix GRAMMAR values."
+ (when (not (member grammar '(infix suffix)))
+ (raise
+ (formatted-message
+ (G_ "The GRAMMAR value must be 'infix or 'suffix, but ~a provided.")
+ grammar)))
+ (fold-right (lambda (e acc)
+ (cons #~(begin
+ (use-modules (ice-9 rdelim))
+ (with-fluids ((%default-port-encoding "UTF-8"))
+ (with-input-from-file #$e read-string)))
+ (if (and (null? acc) (eq? grammar 'infix))
+ acc
+ (cons delimiter acc))))
+ '() ls))
+
+(define (list-of pred?)
+ "Return a procedure that takes a list and check if all the elements of
+the list result in @code{#t} when applying PRED? on them."
+ (lambda (x)
+ (if (list? x)
+ (every pred? x)
+ #f)))
+
+
+(define list-of-strings?
+ (list-of string?))
+
+(define alist? list?)
+
+(define serialize-file-like empty-serializer)
+
+(define (text-config? config)
+ (list-of file-like?))
+(define (serialize-text-config field-name val)
+ #~(string-append #$@(interpose val "\n" 'suffix)))
+
+(define ((generic-serialize-alist-entry serialize-field) entry)
+ "Apply the SERIALIZE-FIELD procedure on the field and value of ENTRY."
+ (match entry
+ ((field . val) (serialize-field field val))))
+
+(define (generic-serialize-alist combine serialize-field fields)
+ "Generate a configuration from an association list FIELDS.
+
+SERIALIZE-FIELD is a procedure that takes two arguments, it will be
+applied on the fields and values of FIELDS using the
+@code{generic-serialize-alist-entry} procedure.
+
+COMBINE is a procedure that takes one or more arguments and combines
+all the alist entries into one value, @code{string-append} or
+@code{append} are usually good candidates for this.
+
+See the @code{serialize-alist} procedure in `@code{(gnu home services
+version-control}' for an example usage.)}"
+ (apply combine
+ (map (generic-serialize-alist-entry serialize-field) fields)))
diff --git a/guix/scripts/home/import.scm b/guix/scripts/home/import.scm
index c977ec3861..611f580e85 100644
--- a/guix/scripts/home/import.scm
+++ b/guix/scripts/home/import.scm
@@ -46,17 +46,15 @@
(home-bash-configuration
,@(if (file-exists? rc)
`((bashrc
- (list (slurp-file-gexp (local-file ,rc)))))
+ (list (local-file ,rc))))
'())
,@(if (file-exists? profile)
`((bash-profile
- (list (slurp-file-gexp
- (local-file ,profile)))))
+ (list (local-file ,profile))))
'())
,@(if (file-exists? logout)
`((bash-logout
- (list (slurp-file-gexp
- (local-file ,logout)))))
+ (list (local-file ,logout))))
'()))))))
diff --git a/tests/guix-home.sh b/tests/guix-home.sh
index 0b5deabeb0..e578559c97 100644
--- a/tests/guix-home.sh
+++ b/tests/guix-home.sh
@@ -54,10 +54,13 @@ trap 'chmod -Rf +w "$test_directory"; rm -rf "$test_directory"' EXIT
# Test 'guix home reconfigure'.
#
+ printf "# dot-bashrc test file for guix home" > "dot-bashrc"
+
cat > "home.scm" <<'EOF'
(use-modules (guix gexp)
(gnu home)
(gnu home services)
+ (gnu home services shells)
(gnu services))
(home-environment
@@ -68,11 +71,33 @@ trap 'chmod -Rf +w "$test_directory"; rm -rf "$test_directory"' EXIT
(list `("config/test.conf"
,(plain-file
"tmp-file.txt"
- "the content of ~/.config/test.conf")))))))
+ "the content of ~/.config/test.conf"))))
+
+ (service home-bash-service-type
+ (home-bash-configuration
+ (guix-defaults? #t)
+ (bashrc
+ (list
+ (local-file (string-append (dirname (current-filename))
+ "/dot-bashrc"))))))
+
+ (simple-service 'home-bash-service-extension-test
+ home-bash-service-type
+ (home-bash-extension
+ (bashrc
+ (list
+ (plain-file
+ "bashrc-test-config.sh"
+ "# the content of bashrc-test-config.sh"))))))))
EOF
guix home reconfigure "${test_directory}/home.scm"
test -d "${HOME}/.guix-home"
+ test -h "${HOME}/.bash_profile"
+ test -h "${HOME}/.bashrc"
+ test "$(tail -n 2 "${HOME}/.bashrc")" == "\
+# dot-bashrc test file for guix home
+# the content of bashrc-test-config.sh"
grep -q "the content of ~/.config/test.conf" "${HOME}/.config/test.conf"
#