summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-08-18 12:59:48 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:14 +0200
commitf22997b1a7e9ae480398c8963a5e28c6c5afa64e (patch)
tree1edd2cad411d9ac6aebaf1a7c667a8ce9939a233 /gnu
parentf0d5ce5a117b8195f2e5a3eb059d3f9038b5a90a (diff)
downloadguix-patches-f22997b1a7e9ae480398c8963a5e28c6c5afa64e.tar
guix-patches-f22997b1a7e9ae480398c8963a5e28c6c5afa64e.tar.gz
gnu: console-setup: Fix cross-compilation.
* gnu/packages/xorg.scm (console-setup)[native-inputs]: Add perl, [arguments]: search for bash in both native-inputs and inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index d5d983a8d2..ecd8c29f21 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6412,25 +6412,28 @@ output.")
" ")))
#t))
(add-before 'build 'make-doubled-bdfs
- (lambda* (#:key inputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
(invoke "make" "-C" "Fonts"
"doubled_bdfs"
(string-append "SHELL="
- (assoc-ref inputs "bash")
+ (assoc-ref (or native-inputs inputs)
+ "bash")
"/bin/bash"))))
(replace 'install
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref %outputs "out")))
(invoke "make" "install-linux"
(string-append "prefix=" out)
(string-append "SHELL="
- (assoc-ref inputs "bash")
+ (assoc-ref (or native-inputs inputs)
+ "bash")
"/bin/bash"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("bdftopcf" ,bdftopcf)
("bdfresize" ,bdfresize)
- ("sharutils" ,sharutils))) ;for 'uuencode'
+ ("sharutils" ,sharutils) ;for 'uuencode'
+ ("perl" ,perl)))
(inputs
`(("perl" ,perl))) ;used by 'ckbcomp'
(synopsis "Set up the Linux console font and keyboard")