summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-08-02 11:32:06 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:14 +0200
commitf0d5ce5a117b8195f2e5a3eb059d3f9038b5a90a (patch)
tree5fb0994345a00835a4a5e8e769001ba6c5e59d97 /gnu
parent8e8855f9aa0521ade0741896b2285d9ddf493fed (diff)
downloadguix-patches-f0d5ce5a117b8195f2e5a3eb059d3f9038b5a90a.tar
guix-patches-f0d5ce5a117b8195f2e5a3eb059d3f9038b5a90a.tar.gz
gnu: procps: Fix cross-compilation.
* gnu/packages/linux.scm (procps)[arguments]: Add configure flags needed from cross-compilation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7ac5a771c8..351087e556 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1141,10 +1141,16 @@ by Robert Shea and Robert Anton Wilson.")
"0r84kwa5fl0sjdashcn4vh7hgfm7ahdcysig3mcjvpmkzi7p9g8h"))))
(build-system gnu-build-system)
(arguments
- '(#:modules ((guix build utils)
+ `(#:modules ((guix build utils)
(guix build gnu-build-system)
(srfi srfi-1)
(srfi srfi-26))
+ ,@(if (%current-target-system)
+ '(#:configure-flags
+ (list
+ "ac_cv_func_malloc_0_nonnull=yes"
+ "ac_cv_func_realloc_0_nonnull=yes"))
+ '())
#:phases
(modify-phases %standard-phases
(add-after