summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-27 10:59:56 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-27 11:04:17 +0100
commitef8742ea69b8998320d4815e2d9820432852517d (patch)
tree5286b0fcd14cc35ace0b2917d6b5d9dc92adf2ca /gnu
parent08c28b6d5a447db6bedc1faa24e98f54c95d9ee8 (diff)
downloadguix-patches-ef8742ea69b8998320d4815e2d9820432852517d.tar
guix-patches-ef8742ea69b8998320d4815e2d9820432852517d.tar.gz
gnu: eigen: Really run tests in verbose mode.
Suggested by Gaël Guennebaud <gael.guennebaud@inria.fr>. * gnu/packages/algebra.scm (eigen)[arguments]: Remove #:test-target. Rename 'build-tests' phase to 'check', and have it run 'ctest -V'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e9edf36d1e..25e1af1750 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -409,26 +409,18 @@ cosine/ sine transforms or DCT/DST).")
'(;; Turn off debugging symbols to save space.
#:build-type "Release"
- ;; Use 'make check', as per
- ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
- #:test-target "check"
-
#:phases (modify-phases %standard-phases
- (add-before 'check 'build-tests
+ (replace 'check
(lambda _
- ;; First build the tests, in parallel.
- ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
(let* ((cores (parallel-job-count))
(dash-j (format #f "-j~a" cores)))
- ;; These variables are supposed to be honored.
- (setenv "EIGEN_MAKE_ARGS" dash-j)
-
- ;; Use '-V' to get more details in case of test
- ;; failures.
- (setenv "EIGEN_CTEST_ARGS"
- (string-append "-V " dash-j))
+ ;; First build the tests, in parallel. See
+ ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
+ (and (zero? (system* "make" "buildtests" dash-j))
- (zero? (system* "make" "buildtests" dash-j))))))))
+ ;; Then run 'CTest' with -V so we get more
+ ;; details upon failure.
+ (zero? (system* "ctest" "-V" dash-j)))))))))
(home-page "http://eigen.tuxfamily.org")
(synopsis "C++ template library for linear algebra")
(description