summaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm22
1 files changed, 7 insertions, 15 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index e9edf36d1e..25e1af1750 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -409,26 +409,18 @@ cosine/ sine transforms or DCT/DST).")
'(;; Turn off debugging symbols to save space.
#:build-type "Release"
- ;; Use 'make check', as per
- ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
- #:test-target "check"
-
#:phases (modify-phases %standard-phases
- (add-before 'check 'build-tests
+ (replace 'check
(lambda _
- ;; First build the tests, in parallel.
- ;; See <http://eigen.tuxfamily.org/index.php?title=Tests>.
(let* ((cores (parallel-job-count))
(dash-j (format #f "-j~a" cores)))
- ;; These variables are supposed to be honored.
- (setenv "EIGEN_MAKE_ARGS" dash-j)
-
- ;; Use '-V' to get more details in case of test
- ;; failures.
- (setenv "EIGEN_CTEST_ARGS"
- (string-append "-V " dash-j))
+ ;; First build the tests, in parallel. See
+ ;; <http://eigen.tuxfamily.org/index.php?title=Tests>.
+ (and (zero? (system* "make" "buildtests" dash-j))
- (zero? (system* "make" "buildtests" dash-j))))))))
+ ;; Then run 'CTest' with -V so we get more
+ ;; details upon failure.
+ (zero? (system* "ctest" "-V" dash-j)))))))))
(home-page "http://eigen.tuxfamily.org")
(synopsis "C++ template library for linear algebra")
(description