summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-16 20:21:59 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-07-09 17:00:20 +0300
commite548f359a71f7514fbfda42bad9fc8c08f13423d (patch)
treeb3816de0055191bb39d5129d9ac6d8ed4f8ccd00 /gnu
parent6540696d6e6479bcb5d3e9eb91a2f5442dd9679d (diff)
downloadguix-patches-e548f359a71f7514fbfda42bad9fc8c08f13423d.tar
guix-patches-e548f359a71f7514fbfda42bad9fc8c08f13423d.tar.gz
gnu: Add rust-rustc-ap-rustc-macros-654.
* gnu/packages/crates-io.scm (rust-rustc-ap-macros-654): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d8bf776d8f..4fdbc0a9cf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20230,6 +20230,35 @@ It is automatically published using the compiler repository at
@url{https://www.github.com/rust-lang/rust}")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-rustc-macros-654
+ (package
+ (name "rust-rustc-ap-rustc-macros")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-rustc_macros" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03zfp8a10jz43z8lsx1drx7g5jimxmbw4w7hs13yvczismb6qs2r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1.0)
+ ("rust-quote" ,rust-quote-1.0)
+ ("rust-syn" ,rust-syn-1.0)
+ ("rust-synstructure" ,rust-synstructure-0.12))))
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis "Automatically published versions of rustc macros")
+ (description
+ "Use macros used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-demangle-0.1
(package
(name "rust-rustc-demangle")