summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index d8bf776d8f..4fdbc0a9cf 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20230,6 +20230,35 @@ It is automatically published using the compiler repository at
@url{https://www.github.com/rust-lang/rust}")
(license (list license:expat license:asl2.0))))
+(define-public rust-rustc-ap-rustc-macros-654
+ (package
+ (name "rust-rustc-ap-rustc-macros")
+ (version "654.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustc-ap-rustc_macros" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "03zfp8a10jz43z8lsx1drx7g5jimxmbw4w7hs13yvczismb6qs2r"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1.0)
+ ("rust-quote" ,rust-quote-1.0)
+ ("rust-syn" ,rust-syn-1.0)
+ ("rust-synstructure" ,rust-synstructure-0.12))))
+ (home-page "https://github.com/alexcrichton/rustc-auto-publish")
+ (synopsis "Automatically published versions of rustc macros")
+ (description
+ "Use macros used in the Rust compiler with this crate.
+It is automatically published using the compiler repository at
+@url{https://www.github.com/rust-lang/rust}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rustc-demangle-0.1
(package
(name "rust-rustc-demangle")