summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 16:31:46 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:26 +0300
commitd30ba2671bb75958abdccb8cec807cbff6f263fc (patch)
tree2e770695c084ba4e13c817ae274d99228f7b1e2c /gnu
parentf4d548b89a9b4bacb4f9cb38e22064f4f855989e (diff)
downloadguix-patches-d30ba2671bb75958abdccb8cec807cbff6f263fc.tar
guix-patches-d30ba2671bb75958abdccb8cec807cbff6f263fc.tar.gz
gnu: Add go-github-com-rogpeppe-go-internal.
* gnu/packages/golang.scm (go-github-com-rogpeppe-go-internal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0eb8091bfc..a0e6851fd5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5558,3 +5558,47 @@ deleting secrets from the system keyring.")
(synopsis "Low-level key/value store in Go")
(description "This package implements a low-level key/value store in Go.")
(license license:expat)))
+
+(define-public go-github-com-rogpeppe-go-internal
+ (package
+ (name "go-github-com-rogpeppe-go-internal")
+ (version "1.6.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rogpeppe/go-internal")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00j2vpp1bsggdvw1winkz23mg0q6drjiir5q0k49pmqx1sh7106l"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rogpeppe/go-internal"
+ ; Source-only package
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (home-page "https://github.com/rogpeppe/go-internal/")
+ (synopsis "Internal packages from the Go standard library")
+ (description "This repository factors out an opinionated selection of
+internal packages and functionality from the Go standard library. Currently
+this consists mostly of packages and testing code from within the Go tool
+implementation.
+
+Included are the following:
+@itemize
+@item dirhash: calculate hashes over directory trees the same way that the Go tool does.
+@item goproxytest: a GOPROXY implementation designed for test use.
+@item gotooltest: Use the Go tool inside test scripts (see testscript below)
+@item imports: list of known architectures and OSs, and support for reading import import statements.
+@item modfile: read and write go.mod files while preserving formatting and comments.
+@item module: module paths and versions.
+@item par: do work in parallel.
+@item semver: semantic version parsing.
+@item testenv: information on the current testing environment.
+@item testscript: script-based testing based on txtar files
+@item txtar: simple text-based file archives for testing.
+@end itemize\n")
+ (license license:bsd-3)))