summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 16:20:39 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:26 +0300
commitf4d548b89a9b4bacb4f9cb38e22064f4f855989e (patch)
treec4ff747bf07d5b4aff50c80a9d525fac746a64f9 /gnu
parentea60163a9d2462581ff584dba55cfa20b6acee49 (diff)
downloadguix-patches-f4d548b89a9b4bacb4f9cb38e22064f4f855989e.tar
guix-patches-f4d548b89a9b4bacb4f9cb38e22064f4f855989e.tar.gz
gnu: Add go-etcd-io-bbolt.
* gnu/packages/golang.scm (go-etcd-io-bbolt): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c19b9448ea..0eb8091bfc 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5537,3 +5537,24 @@ bindings for the D-Bus message bus system.")
(description "@code{go-keyring} is a library for setting, getting and
deleting secrets from the system keyring.")
(license license:expat)))
+
+(define-public go-etcd-io-bbolt
+ (package
+ (name "go-etcd-io-bbolt")
+ (version "1.3.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/bbolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h64gipvcg7060byv5wjlf524kqwj12p3v08kfh4ygv46vpm8p2r"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "go.etcd.io/bbolt"))
+ (home-page "https://pkg.go.dev/go.etcd.io/bbolt/")
+ (synopsis "Low-level key/value store in Go")
+ (description "This package implements a low-level key/value store in Go.")
+ (license license:expat)))