summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:22:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:40 +0200
commitc9bbc7274f6975ba567b6ebc0c57bfadb047897d (patch)
tree1ecb513baad9c90fe02e68e6f32f614336ad934b /gnu
parent2d51e19ab396eda685d09a3585d5572983538e68 (diff)
downloadguix-patches-c9bbc7274f6975ba567b6ebc0c57bfadb047897d.tar
guix-patches-c9bbc7274f6975ba567b6ebc0c57bfadb047897d.tar.gz
gnu: Add texlive-mp3d.
* gnu/packages/tex.scm (texlive-mp3d): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e32e26d040..2d9683104d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5646,6 +5646,24 @@ algorithms are available to solve the ODEs. The picture is translated into
the @code{minim-mp} MetaPost processor.")
(license license:eupl1.2)))
+(define-public texlive-mp3d
+ (package
+ (name "texlive-mp3d")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/mp3d/" "metapost/mp3d/")
+ (base32
+ "1qfg4ifm5z72sr8vimibmpmqh0cxzipiy4jr8rbq5qsj2mfqzphd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mp3d")
+ (synopsis "3D animations")
+ (description
+ "This library creates animations of 3-dimensional objects (such as
+polyhedra) in MetaPost.")
+ (license license:lppl)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")