summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:07:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:33 +0200
commitc489a82a1384f73c82af9bffbfac205df21d6367 (patch)
tree6bc7d4ce541aa83352ae15c156d682bd7df47da1 /gnu
parent3678287e9973700d4f74972cb47baec7b2f4c918 (diff)
downloadguix-patches-c489a82a1384f73c82af9bffbfac205df21d6367.tar
guix-patches-c489a82a1384f73c82af9bffbfac205df21d6367.tar.gz
gnu: Add texlive-emp.
* gnu/packages/tex.scm (texlive-emp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c26e1d891..353c72b590 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4912,6 +4912,31 @@ envisage including a DVI page into an EPS files generated by MetaPost. Such
files allow pages to include other pages.")
(license license:public-domain)))
+(define-public texlive-emp
+ (package
+ (name "texlive-emp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/emp/" "source/latex/emp/"
+ "tex/latex/emp/")
+ (base32
+ "183qwxxjws4l0jrn92dj4qd8avnv9gq2rk1zqak0h48wxlp0fpyq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/emp")
+ (synopsis "Encapsulate MetaPost figures in a document")
+ (description
+ "Emp is a package for encapsulating MetaPost figures in LaTeX: the
+package provides environments where you can place MetaPost commands, and means
+of using that code as fragments for building up figures to include in your
+document. So, with Emp, the procedure is to run your document with LaTeX, run
+MetaPost, and then complete running your document in the normal way. Emp is
+therefore useful for keeping illustrations in synchrony with the text. It
+also frees you from inventing descriptive names for PostScript files that fit
+into the confines of file system conventions.")
+ (license license:gpl3+)))
+
(define-public texlive-enctex
(package
(name "texlive-enctex")