summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:06:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:33 +0200
commit3678287e9973700d4f74972cb47baec7b2f4c918 (patch)
treec6547216f1cb71e3bba9a62b0dfab8de65bb2d5e /gnu
parent40ba14a0e06667dbccec813a6978d7024dbb5768 (diff)
downloadguix-patches-3678287e9973700d4f74972cb47baec7b2f4c918.tar
guix-patches-3678287e9973700d4f74972cb47baec7b2f4c918.tar.gz
gnu: Add texlive-dviincl.
* gnu/packages/tex.scm (texlive-dviincl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 49f3496453..3c26e1d891 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4892,6 +4892,26 @@ derivation trees (such as used in sequent calculus, type inference,
programming language semantics...).")
(license license:lppl)))
+(define-public texlive-dviincl
+ (package
+ (name "texlive-dviincl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/dviincl/" "metapost/dviincl/")
+ (base32
+ "05f6ll7cq4ad4i4nkzrjnlqg1456is06fbmjiinadahf7yrqk3lw")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/dviincl")
+ (synopsis "Include a DVI page into MetaPost output")
+ (description
+ "DVItoMP is one of the auxiliary programs available to any MetaPost
+package; it converts a DVI file into a MetaPost file. Using it, one can
+envisage including a DVI page into an EPS files generated by MetaPost. Such
+files allow pages to include other pages.")
+ (license license:public-domain)))
+
(define-public texlive-enctex
(package
(name "texlive-enctex")