summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:25:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:43 +0200
commitc38de584f12b39059a3fb515296bbd3b49ae1aaa (patch)
tree3261c761194d5ffb5982104b6b147d8257d7b5df /gnu
parent0dc1f9082134b786bdd091d4cd4e15096e332d13 (diff)
downloadguix-patches-c38de584f12b39059a3fb515296bbd3b49ae1aaa.tar
guix-patches-c38de584f12b39059a3fb515296bbd3b49ae1aaa.tar.gz
gnu: Add texlive-repere.
* gnu/packages/tex.scm (texlive-repere): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b268fa2ab8..cf5f64a110 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6029,6 +6029,26 @@ corresponding thing with the page reference of the label.")
(define-deprecated-package texlive-latex-refcount texlive-refcount)
+(define-public texlive-repere
+ (package
+ (name "texlive-repere")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/repere/" "metapost/repere/")
+ (base32
+ "06p184mgv0cac36pp1srrd80axvkxf155l3jf01dnvd2x1d7dwlk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/repere")
+ (synopsis "MetaPost macros for secondary school mathematics teachers")
+ (description
+ "This package provides MetaPost macros for drawing secondary school
+mathematics figures in a coordinate system: axis, grids points, vectors
+functions (curves, tangents, integrals, sequences) statistic diagrams plane
+geometry (polygons, circles), arrays and game boards.")
+ (license license:lppl1.3c)))
+
(define-public texlive-selinput
(package
(name "texlive-selinput")