summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:25:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:42 +0200
commit0dc1f9082134b786bdd091d4cd4e15096e332d13 (patch)
tree6956569881c5def565599f5250c922d1f12c76d7 /gnu
parented38b52e5bff2e3da45c6ede607847fe54bdca9f (diff)
downloadguix-patches-0dc1f9082134b786bdd091d4cd4e15096e332d13.tar
guix-patches-0dc1f9082134b786bdd091d4cd4e15096e332d13.tar.gz
gnu: Add texlive-piechartmp.
* gnu/packages/tex.scm (texlive-piechartmp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9c861c230b..b268fa2ab8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5933,6 +5933,28 @@ available for LuaTeX by reimplementing them using Lua.")
(define-deprecated-package texlive-latex-pdftexcmds texlive-pdftexcmds)
+(define-public texlive-piechartmp
+ (package
+ (name "texlive-piechartmp")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/piechartmp/"
+ "metapost/piechartmp/")
+ (base32
+ "0xf83k85bwbdy4d1m23zyk5zjg9qw960q4rkgf2i1449w30gf3hp")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/piechartmp")
+ (synopsis "Draw pie-charts using MetaPost")
+ (description
+ "The @code{piechartmp} package is an easy way to draw pie-charts with
+MetaPost. The package implements an interface that enables users with little
+MetaPost experience to draw charts. A highlight of the package is the
+possibility of suppressing some segments of the chart, thus creating the
+possibility of several charts from the same data.")
+ (license license:lppl)))
+
(define-public texlive-psfrag
(package
(name "texlive-psfrag")